aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlec Thomas <alec@swapoff.org>2013-08-19 00:01:01 -0400
committerAlec Thomas <alec@swapoff.org>2013-08-19 00:01:01 -0400
commitc99603588ec25f17863524b9cbabd31c69f4fa74 (patch)
treeb9679ba8b1278c0a16173e2368967117a5968273 /CMakeLists.txt
parentb0fe85294568485b1cd06afa0e9ab9b7b0beea62 (diff)
Add Doxygen file.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fce2a50..45ebf01 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,12 @@
cmake_minimum_required(VERSION 2.8)
-project(EntityX)
+project(EntityX CXX)
+
+set(ENTITYX_MAJOR_VERSION 0)
+set(ENTITYX_MINOR_VERSION 8)
+set(ENTITYX_PATCH_VERSION 1)
+set(ENTITYX_VERSION ${ENTITYX_MAJOR_VERSION}.${ENTITYX_MINOR_VERSION}.${ENTITYX_PATCH_VERSION})
+
+
include_directories(${CMAKE_CURRENT_LIST_DIR})
set(ENTITYX_BUILD_TESTING false CACHE BOOL "Enable building of tests.")