aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlec Thomas <alec@swapoff.org>2012-10-24 17:24:11 -0400
committerAlec Thomas <alec@swapoff.org>2012-10-24 17:24:11 -0400
commit37795d152797dab8afb272a210e8fa0f5541829c (patch)
tree515567ff278a78a88f8f933f4dcbeca19ebed837 /CMakeLists.txt
parentfabb85ec3f30cf264587e4eb8cfa87efa75457b0 (diff)
Name shared library entityx (rather than ..._shared).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index afb3146..1da9770 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,6 +62,7 @@ set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O2 -g")
set(sources entityx/Components.cc entityx/System.cc entityx/Event.cc entityx/Entity.cc entityx/Manager.cc)
add_library(entityx STATIC ${sources})
add_library(entityx_shared SHARED ${sources})
+set_target_properties(entityx_shared PROPERTIES OUTPUT_NAME entityx)
include_directories(
${Boost_INCLUDE_DIR}