aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlec Thomas <alec@swapoff.org>2013-08-21 22:57:32 -0400
committerAlec Thomas <alec@swapoff.org>2013-08-21 22:57:32 -0400
commit5716e2ef6578e8cd2ea2b2e266d9f438c233ed0f (patch)
treed87d7d62a9ecc260909f3233409d0c8b902ec5c3 /CMakeLists.txt
parentbe03c3a3d4e8824c3b909648b46910b4cdbc72e1 (diff)
Revert "Switch to boost::signals2."
Until I have the time to make the tests work. This reverts commit be03c3a3d4e8824c3b909648b46910b4cdbc72e1.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 23206e7..e53de9a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -76,6 +76,7 @@ require(HAVE_STDINT_H "stdint.h")
set(Boost_USE_STATIC_LIBS OFF)
set(Boost_USE_MULTITHREADED ON)
set(Boost_USE_STATIC_RUNTIME OFF)
+find_package(Boost 1.48.0 REQUIRED COMPONENTS signals)
find_package(Boost 1.48.0 COMPONENTS python)
include_directories(${Boost_INCLUDE_DIR})
@@ -134,7 +135,7 @@ if (Boost_PYTHON_LIBRARY)
endif (Boost_PYTHON_LIBRARY)
if (ENTITYX_BUILD_TESTING)
- find_package(Boost 1.48.0 REQUIRED COMPONENTS timer system)
+ find_package(Boost 1.48.0 REQUIRED COMPONENTS signals timer system)
add_subdirectory(gtest-1.6.0)
include_directories(${gtest_SOURCE_DIR}/include ${gtest_SOURCE_DIR})
enable_testing()