aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index af6d17c..fc89cd3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -136,6 +136,21 @@ configure_file(
${CMAKE_CURRENT_SOURCE_DIR}/entityx/config.h
)
+
+if (NOT WINDOWS OR CYGWIN)
+ set(entityx_libs -lentityx)
+
+ configure_file(
+ ${CMAKE_CURRENT_SOURCE_DIR}/entityx.pc.in
+ ${CMAKE_CURRENT_BINARY_DIR}/entityx.pc
+ )
+
+ install(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/entityx.pc
+ DESTINATION "lib/pkgconfig"
+ )
+endif()
+
install(
DIRECTORY "entityx"
DESTINATION "include"