From 799f95e382ae59275d24ed3724e03ad1d7d668f5 Mon Sep 17 00:00:00 2001
From: Zack Hovatter <zackhovatter@gmail.com>
Date: Sun, 19 Jan 2014 17:40:58 -0600
Subject: Add pkg-config source file

---
 CMakeLists.txt | 15 +++++++++++++++
 1 file changed, 15 insertions(+)

(limited to 'CMakeLists.txt')

diff --git a/CMakeLists.txt b/CMakeLists.txt
index af6d17c..fc89cd3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -136,6 +136,21 @@ configure_file(
     ${CMAKE_CURRENT_SOURCE_DIR}/entityx/config.h
 )
 
+
+if (NOT WINDOWS OR CYGWIN)
+    set(entityx_libs -lentityx)
+
+    configure_file(
+        ${CMAKE_CURRENT_SOURCE_DIR}/entityx.pc.in
+        ${CMAKE_CURRENT_BINARY_DIR}/entityx.pc
+        )
+
+    install(
+        FILES ${CMAKE_CURRENT_BINARY_DIR}/entityx.pc
+        DESTINATION "lib/pkgconfig"
+        )
+endif()
+
 install(
     DIRECTORY "entityx"
     DESTINATION "include"
-- 
cgit v1.2.3