aboutsummaryrefslogtreecommitdiffstats
path: root/lib/LuaBridge/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Belle-Isle <drumsetmonkey@gmail.com>2019-08-28 00:57:57 -0400
committerAndy Belle-Isle <drumsetmonkey@gmail.com>2019-08-28 00:57:57 -0400
commit85fb2bff38b2ef6cb17e86c5f602ee09a365b117 (patch)
treea8066d33233ec9b6a2b9bb281a1de040ab96be7b /lib/LuaBridge/CMakeLists.txt
parent787393dd86d6c37b5680847dd4eef14406a86687 (diff)
Added LuaBridge support
Diffstat (limited to 'lib/LuaBridge/CMakeLists.txt')
-rw-r--r--lib/LuaBridge/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/lib/LuaBridge/CMakeLists.txt b/lib/LuaBridge/CMakeLists.txt
new file mode 100644
index 0000000..e18f198
--- /dev/null
+++ b/lib/LuaBridge/CMakeLists.txt
@@ -0,0 +1,18 @@
+cmake_minimum_required (VERSION 3.5)
+
+project (LuaBridge)
+
+set (CMAKE_CXX_STANDARD 11)
+
+option (LUABRIDGE_NO_CXX11 "Use C++11 standard if supported by compiler" OFF)
+
+if (LUABRIDGE_NO_CXX11)
+ add_definitions (-DLUABRIDGE_NO_CXX11)
+endif ()
+
+set (gtest_force_shared_crt ON CACHE BOOL "Use /MD and /MDd" FORCE)
+add_subdirectory (third_party/gtest)
+
+add_subdirectory (Source)
+
+add_subdirectory (Tests)