aboutsummaryrefslogtreecommitdiffstats
path: root/lib/sol2/meson.build
diff options
context:
space:
mode:
authorAndy Belle-Isle <drumsetmonkey@gmail.com>2019-08-30 00:19:31 -0400
committerAndy Belle-Isle <drumsetmonkey@gmail.com>2019-08-30 00:19:31 -0400
commitbd3fe0cac583739bc0d7c4b5c8f301bb350abca0 (patch)
tree7eeb1aabcebd6999de1c3457d0882246ec0ff4d4 /lib/sol2/meson.build
parent2662ac356ce14dacfbc91689fd37244facff4989 (diff)
Renamed lib to deps so github will ignore it for language stats
Diffstat (limited to 'lib/sol2/meson.build')
-rw-r--r--lib/sol2/meson.build60
1 files changed, 0 insertions, 60 deletions
diff --git a/lib/sol2/meson.build b/lib/sol2/meson.build
deleted file mode 100644
index dbd53a1..0000000
--- a/lib/sol2/meson.build
+++ /dev/null
@@ -1,60 +0,0 @@
-project('sol3', 'cpp')
-
-# Find lua dependency
-if get_option('lua_cpp')
- lua_cpp = 'true'
-else
- lua_cpp = 'false'
-endif
-
-lua_dep = dependency('lua', fallback: [ 'lua', 'lua_dep' ], default_options: [ 'lua_cpp=' + lua_cpp ])
-
-# Set compiler flags if we're compiling lua as C++.
-compile_args = []
-
-if get_option('lua_cpp')
- compile_args = [ '-DSOL_USING_CXX_LUA=1' ]
-endif
-
-# Expose standard dependency.
-sol2_dep = declare_dependency(
- include_directories: include_directories('./include'),
- compile_args: compile_args,
- dependencies: [ lua_dep ],
-)
-
-# Single header targets requested.
-if get_option('single')
-
- # Check if we have python installed (required for creating single).
- python = find_program('python3', required: false)
-
- if not python.found()
- python = find_program('python', required: false)
- endif
-
- if not python.found()
- error('Could not locate Python. Python is required when building a single header.')
- endif
-
- # List all headers that the single header comprises of.
- cmd = run_command(python, 'list_headers.py')
-
- if cmd.returncode() != 0
- error('Could not list sol3 header files.')
- endif
-
- # Create our custom target to generate the single header file.
- sol2_single = custom_target('sol2_single',
- input: cmd.stdout().strip().split('\n'),
- output: 'sol.hpp',
- command: [ python, files('single/single.py'), '--input', './include', '--output', '@OUTPUT@' ]
- )
-
- # Expose the dependency.
- sol2_dep = declare_dependency(
- sources: [ sol2_single ],
- compile_args: compile_args,
- dependencies: [ lua_dep ],
- )
-endif