aboutsummaryrefslogtreecommitdiffstats
path: root/deps/sol2/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'deps/sol2/tests/CMakeLists.txt')
-rw-r--r--deps/sol2/tests/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/deps/sol2/tests/CMakeLists.txt b/deps/sol2/tests/CMakeLists.txt
new file mode 100644
index 0000000..2e7ee37
--- /dev/null
+++ b/deps/sol2/tests/CMakeLists.txt
@@ -0,0 +1,26 @@
+# # # # sol3
+# The MIT License (MIT)
+#
+# Copyright (c) 2013-2019 Rapptz, ThePhD, and contributors
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy of
+# this software and associated documentation files (the "Software"), to deal in
+# the Software without restriction, including without limitation the rights to
+# use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of
+# the Software, and to permit persons to whom the Software is furnished to do so,
+# subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in all
+# copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
+# FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
+# COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+# # # # sol3 tests
+
+add_subdirectory(runtime_tests)
+add_subdirectory(compile_tests)