summaryrefslogtreecommitdiffstats
path: root/Drivers/CMSIS/DSP/Source/ControllerFunctions/CMakeLists.txt
diff options
context:
space:
mode:
authorClyne Sullivan <clyne@bitgloo.com>2025-01-29 21:34:25 -0500
committerClyne Sullivan <clyne@bitgloo.com>2025-01-29 21:34:25 -0500
commit5b81bc8ccbd342b8566d88fc9f17a73aec03b5b6 (patch)
treecc57486912cfa74c6440d8b97c28f451ec787d78 /Drivers/CMSIS/DSP/Source/ControllerFunctions/CMakeLists.txt
initial commit
Diffstat (limited to 'Drivers/CMSIS/DSP/Source/ControllerFunctions/CMakeLists.txt')
-rw-r--r--Drivers/CMSIS/DSP/Source/ControllerFunctions/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/Drivers/CMSIS/DSP/Source/ControllerFunctions/CMakeLists.txt b/Drivers/CMSIS/DSP/Source/ControllerFunctions/CMakeLists.txt
new file mode 100644
index 0000000..12dedb4
--- /dev/null
+++ b/Drivers/CMSIS/DSP/Source/ControllerFunctions/CMakeLists.txt
@@ -0,0 +1,41 @@
+cmake_minimum_required (VERSION 3.14)
+
+project(CMSISDSPController)
+
+include(configLib)
+include(configDsp)
+
+add_library(CMSISDSPController STATIC)
+
+configLib(CMSISDSPController ${ROOT})
+configDsp(CMSISDSPController ${ROOT})
+
+include(interpol)
+interpol(CMSISDSPController)
+
+if (CONFIGTABLE AND ALLFAST)
+ target_compile_definitions(CMSISDSPController PUBLIC ARM_ALL_FAST_TABLES)
+endif()
+
+target_sources(CMSISDSPController PRIVATE arm_pid_init_f32.c)
+target_sources(CMSISDSPController PRIVATE arm_pid_init_q15.c)
+target_sources(CMSISDSPController PRIVATE arm_pid_init_q31.c)
+target_sources(CMSISDSPController PRIVATE arm_pid_reset_f32.c)
+target_sources(CMSISDSPController PRIVATE arm_pid_reset_q15.c)
+target_sources(CMSISDSPController PRIVATE arm_pid_reset_q31.c)
+
+if (NOT CONFIGTABLE OR ALLFAST OR ARM_SIN_COS_F32)
+target_sources(CMSISDSPController PRIVATE arm_sin_cos_f32.c)
+endif()
+
+if (NOT CONFIGTABLE OR ALLFAST OR ARM_SIN_COS_Q31)
+target_sources(CMSISDSPController PRIVATE arm_sin_cos_q31.c)
+endif()
+
+
+
+### Includes
+target_include_directories(CMSISDSPController PUBLIC "${DSP}/Include")
+
+
+