summaryrefslogtreecommitdiffstats
path: root/Drivers/CMSIS/NN/CMakeLists.txt
diff options
context:
space:
mode:
authorClyne Sullivan <clyne@bitgloo.com>2025-01-29 21:34:25 -0500
committerClyne Sullivan <clyne@bitgloo.com>2025-01-29 21:34:25 -0500
commit5b81bc8ccbd342b8566d88fc9f17a73aec03b5b6 (patch)
treecc57486912cfa74c6440d8b97c28f451ec787d78 /Drivers/CMSIS/NN/CMakeLists.txt
initial commit
Diffstat (limited to 'Drivers/CMSIS/NN/CMakeLists.txt')
-rw-r--r--Drivers/CMSIS/NN/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/Drivers/CMSIS/NN/CMakeLists.txt b/Drivers/CMSIS/NN/CMakeLists.txt
new file mode 100644
index 0000000..ad3b748
--- /dev/null
+++ b/Drivers/CMSIS/NN/CMakeLists.txt
@@ -0,0 +1,29 @@
+#
+# Copyright (c) 2019-2021 Arm Limited.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+cmake_minimum_required(VERSION 3.15.6)
+
+project(CMSISNN)
+
+set(CMSIS_PATH "${CMAKE_CURRENT_SOURCE_DIR}/../..")
+
+option(BUILD_CMSIS_NN_FUNCTIONS "Build CMSIS-NN Source." ON)
+
+if(BUILD_CMSIS_NN_FUNCTIONS)
+ add_subdirectory(Source)
+endif()