aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZack Hovatter <zackhovatter@gmail.com>2014-01-19 17:40:58 -0600
committerZack Hovatter <zackhovatter@gmail.com>2014-01-19 17:40:58 -0600
commit799f95e382ae59275d24ed3724e03ad1d7d668f5 (patch)
treed4e4e661c0fb650794234b06466e41938f1d35c1 /CMakeLists.txt
parent5bd2040e92c7632018cc8bbe111e1afbdbe255ef (diff)
Add pkg-config source file
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index af6d17c..fc89cd3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -136,6 +136,21 @@ configure_file(
${CMAKE_CURRENT_SOURCE_DIR}/entityx/config.h
)
+
+if (NOT WINDOWS OR CYGWIN)
+ set(entityx_libs -lentityx)
+
+ configure_file(
+ ${CMAKE_CURRENT_SOURCE_DIR}/entityx.pc.in
+ ${CMAKE_CURRENT_BINARY_DIR}/entityx.pc
+ )
+
+ install(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/entityx.pc
+ DESTINATION "lib/pkgconfig"
+ )
+endif()
+
install(
DIRECTORY "entityx"
DESTINATION "include"