aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlec Thomas <alec@swapoff.org>2013-03-11 22:03:14 -0400
committerAlec Thomas <alec@swapoff.org>2013-03-11 22:03:14 -0400
commit3b79b1a7dcf3f4a3d49d0297551bd7e3e4cc1689 (patch)
tree478cba45298b41dd15edb539e94e3d0f9fa45a83 /CMakeLists.txt
parentddd703b00b6a3f1bc601e98548b410753fbfc340 (diff)
Add some benchmarks.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7ee2745..bfc22aa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,7 @@ macro(create_test TARGET_NAME SOURCE)
entityx
glog
${Boost_LIBRARIES}
+ ${Boost_TIMER_LIBRARY}
${Boost_SIGNALS_LIBRARY}
${GTEST_BOTH_LIBRARIES}
)
@@ -75,6 +76,7 @@ include_directories(
set(BUILD_TESTING false CACHE BOOL "Enable building of tests")
if (BUILD_TESTING)
+ find_package(Boost 1.48.0 REQUIRED COMPONENTS signals timer system)
enable_testing()
find_package(GTest REQUIRED)
include_directories(${GTEST_INCLUDE_DIRS})
@@ -82,6 +84,7 @@ if (BUILD_TESTING)
create_test(component_test entityx/Components_test.cc)
create_test(event_test entityx/Event_test.cc)
create_test(system_test entityx/System_test.cc)
+ create_test(benchmarks_test entityx/Benchmarks_test.cc)
endif (BUILD_TESTING)
file(GLOB headers "${CMAKE_CURRENT_SOURCE_DIR}/entityx/*.h")