aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlec Thomas <alec@swapoff.org>2014-03-02 22:49:41 +1100
committerAlec Thomas <alec@swapoff.org>2014-03-02 22:49:41 +1100
commitcc5201fd22250a36dbfaeec09b90750ff489d2f1 (patch)
tree85bfd12e7c1a7cb904a25bfd58d9a0d89868cd60 /CMakeLists.txt
parentf21209417a2c4b3c874d8f58b653489c5cb2494f (diff)
Use raw pointers for components, allocated from pools.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1b6efb6..fc39440 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -122,7 +122,7 @@ endif()
# Things to install
set(install_libs entityx)
-set(sources entityx/System.cc entityx/Event.cc entityx/Entity.cc entityx/help/Timer.cc)
+set(sources entityx/System.cc entityx/Event.cc entityx/Entity.cc entityx/help/Timer.cc entityx/help/Pool.cc)
add_library(entityx STATIC ${sources})
if (ENTITYX_BUILD_SHARED)
@@ -140,6 +140,7 @@ if (ENTITYX_BUILD_TESTING)
add_subdirectory(gtest-1.6.0)
include_directories(${gtest_SOURCE_DIR}/include ${gtest_SOURCE_DIR})
enable_testing()
+ create_test(pool_test entityx/help/Pool_test.cc)
create_test(entity_test entityx/Entity_test.cc)
create_test(event_test entityx/Event_test.cc)
create_test(system_test entityx/System_test.cc)