aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMario Liebisch <mario.liebisch@gmail.com>2014-12-15 21:35:51 +0100
committerMario Liebisch <mario.liebisch@gmail.com>2014-12-15 21:44:12 +0100
commite3f4198697c850f4b37ad618882c32001c05bf67 (patch)
tree371e2a3cfddf26bf1cc749ea6587ec805e929cdb /CMakeLists.txt
parentb12246386b724c08d5d67322bb9138d1e79d12ca (diff)
Added CMake Find_Package script and debug suffix
* This allows easy inclusion of EntityX in CMake projects using `Find_Package(EntityX)`. * Also debug versions now use the `-d` suffix, no longer overwriting release builds (e.g. `entityx-d.lib` rather than `entityx.lib`).
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 77a94a7..8d8601c 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -120,6 +120,7 @@ set(install_libs entityx)
set(sources entityx/System.cc entityx/Event.cc entityx/Entity.cc entityx/help/Timer.cc entityx/help/Pool.cc)
add_library(entityx STATIC ${sources})
+set_target_properties(entityx PROPERTIES DEBUG_POSTFIX -d)
if (ENTITYX_BUILD_SHARED)
message("-- Building shared libraries (-DENTITYX_BUILD_SHARED=0 to only build static librarires)")