aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 13 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e53de9a..667549f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,10 +11,11 @@ include_directories(${CMAKE_CURRENT_LIST_DIR})
set(ENTITYX_BUILD_TESTING false CACHE BOOL "Enable building of tests.")
set(ENTITYX_RUN_BENCHMARKS false CACHE BOOL "Run benchmarks (in conjunction with -DENTITYX_BUILD_TESTING=1).")
set(ENTITYX_MAX_COMPONENTS 64 CACHE STRING "Set the maximum number of components.")
-set(ENTITYX_USE_CPP11_STDLIB false CACHE BOOL "Use the C++11 stdlib (-stdlib=libc++).")
+set(ENTITYX_USE_CPP11_STDLIB false CACHE BOOL "For Clang, specify whether to use libc++ (-stdlib=libc++).")
# Check for which shared_ptr implementation to use.
set(ENTITYX_USE_STD_SHARED_PTR false CACHE BOOL "Use std::shared_ptr<T> rather than boost::shared_ptr<T>?")
set(ENTITYX_BUILD_SHARED true CACHE BOOL "Build shared libraries?")
+set(ENTITYX_BUILD_PYTHON true CACHE BOOL "Build entityx::python?")
include(${CMAKE_ROOT}/Modules/CheckIncludeFile.cmake)
include(CheckCXXSourceCompiles)
@@ -76,8 +77,12 @@ require(HAVE_STDINT_H "stdint.h")
set(Boost_USE_STATIC_LIBS OFF)
set(Boost_USE_MULTITHREADED ON)
set(Boost_USE_STATIC_RUNTIME OFF)
-find_package(Boost 1.48.0 REQUIRED COMPONENTS signals)
-find_package(Boost 1.48.0 COMPONENTS python)
+if (ENTITYX_BUILD_PYTHON)
+ message("-- Building with Python support (-DENTITYX_BUILD_PYTHON=0 to disable)")
+ find_package(Boost 1.48.0 COMPONENTS python)
+else (ENTITYX_BUILD_PYTHON)
+ message("-- Python support disabled")
+endif (ENTITYX_BUILD_PYTHON)
include_directories(${Boost_INCLUDE_DIR})
set(CMAKE_CXX_FLAGS_DEBUG "-O0 -g")
@@ -106,7 +111,7 @@ endif (ENTITYX_BUILD_SHARED)
include_directories(${Boost_INCLUDE_DIR})
-if (Boost_PYTHON_LIBRARY)
+if (ENTITYX_BUILD_PYTHON AND Boost_PYTHON_LIBRARY)
message("-- Found boost::python, building entityx/python")
find_package(PythonLibs REQUIRED)
include_directories(${PYTHON_INCLUDE_DIRS})
@@ -132,10 +137,12 @@ if (Boost_PYTHON_LIBRARY)
set_target_properties(entityx_python_shared PROPERTIES OUTPUT_NAME entityx_python)
list(APPEND install_libs entityx_python_shared)
endif (ENTITYX_BUILD_SHARED)
-endif (Boost_PYTHON_LIBRARY)
+ set(CMAKE_REQUIRED_FLAGS ${CMAKE_CXX_FLAGS})
+ include(CheckNeedGetPointer.cmake)
+endif (ENTITYX_BUILD_PYTHON AND Boost_PYTHON_LIBRARY)
if (ENTITYX_BUILD_TESTING)
- find_package(Boost 1.48.0 REQUIRED COMPONENTS signals timer system)
+ find_package(Boost 1.48.0 REQUIRED COMPONENTS timer system)
add_subdirectory(gtest-1.6.0)
include_directories(${gtest_SOURCE_DIR}/include ${gtest_SOURCE_DIR})
enable_testing()