aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorClyne <clyne@bitgloo.com>2022-05-24 17:38:05 -0400
committerClyne <clyne@bitgloo.com>2022-05-24 17:38:05 -0400
commit5902a67796000c7546d07fa778b26619c4588c3a (patch)
tree1c1fa04635a3c248d07fde4dce8857885ca23952 /CMakeLists.txt
parent1cf4908a23dc5537be0bab1089ffcaa7079d5434 (diff)
parentdff847ff4455e7b8c5123167a7d01afe7c45f585 (diff)
Merge pull request 'devel: Ready for pre-release' (#1) from devel into masterv0.1
Reviewed-on: https://code.bitgloo.com/clyne/stmdspgui/pulls/1
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..54f7086
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,33 @@
+cmake_minimum_required(VERSION 3.10)
+
+project(stmdspgui VERSION 0.5)
+
+set(CMAKE_CXX_STANDARD 20)
+set(CMAKE_CXX_STANDARD_REQUIRED True)
+
+add_compile_options(-O0 -ggdb -g3)
+
+file(GLOB SRC_IMGUI_BACKENDS "${CMAKE_SOURCE_DIR}/source/imgui/backends/*.cpp")
+file(GLOB SRC_IMGUI "${CMAKE_SOURCE_DIR}/source/imgui/*.cpp")
+file(GLOB SRC_STMDSP "${CMAKE_SOURCE_DIR}/source/stmdsp/*.cpp")
+file(GLOB SRC_STMDSPGUI "${CMAKE_SOURCE_DIR}/source/*.cpp")
+
+set_property(SOURCE ${SRC_STMDSPGUI} PROPERTY COMPILE_FLAGS "-Wall -Wextra -Wpedantic")
+
+add_executable(stmdspgui
+ source/serial/src/serial.cc
+ source/serial/src/impl/unix.cc
+ source/serial/src/impl/list_ports/list_ports_linux.cc
+ ${SRC_IMGUI_BACKENDS}
+ ${SRC_IMGUI}
+ ${SRC_STMDSP}
+ ${SRC_STMDSPGUI})
+
+target_include_directories(stmdspgui PUBLIC
+ ${CMAKE_SOURCE_DIR}/source
+ ${CMAKE_SOURCE_DIR}/source/imgui
+ ${CMAKE_SOURCE_DIR}/source/stmdsp
+ ${CMAKE_SOURCE_DIR}/source/serial/include)
+
+target_link_libraries(stmdspgui PRIVATE SDL2 GL pthread)
+