summaryrefslogtreecommitdiffstats
path: root/Drivers/CMSIS/DSP/Source/BasicMathFunctions/CMakeLists.txt
diff options
context:
space:
mode:
authorClyne Sullivan <clyne@bitgloo.com>2025-01-29 21:34:25 -0500
committerClyne Sullivan <clyne@bitgloo.com>2025-01-29 21:34:25 -0500
commit5b81bc8ccbd342b8566d88fc9f17a73aec03b5b6 (patch)
treecc57486912cfa74c6440d8b97c28f451ec787d78 /Drivers/CMSIS/DSP/Source/BasicMathFunctions/CMakeLists.txt
initial commit
Diffstat (limited to 'Drivers/CMSIS/DSP/Source/BasicMathFunctions/CMakeLists.txt')
-rw-r--r--Drivers/CMSIS/DSP/Source/BasicMathFunctions/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/Drivers/CMSIS/DSP/Source/BasicMathFunctions/CMakeLists.txt b/Drivers/CMSIS/DSP/Source/BasicMathFunctions/CMakeLists.txt
new file mode 100644
index 0000000..37802a8
--- /dev/null
+++ b/Drivers/CMSIS/DSP/Source/BasicMathFunctions/CMakeLists.txt
@@ -0,0 +1,41 @@
+cmake_minimum_required (VERSION 3.14)
+
+project(CMSISDSPBasicMath)
+
+include(configLib)
+include(configDsp)
+
+file(GLOB SRCF64 "./*_f64.c")
+file(GLOB SRCF32 "./*_f32.c")
+file(GLOB SRCF16 "./*_f16.c")
+file(GLOB SRCQ31 "./*_q31.c")
+file(GLOB SRCQ15 "./*_q15.c")
+file(GLOB SRCQ7 "./*_q7.c")
+
+file(GLOB SRCU32 "./*_u32.c")
+file(GLOB SRCU16 "./*_u16.c")
+file(GLOB SRCU8 "./*_u8.c")
+
+add_library(CMSISDSPBasicMath STATIC ${SRCF64})
+target_sources(CMSISDSPBasicMath PRIVATE ${SRCF32})
+
+if ((NOT ARMAC5) AND (NOT DISABLEFLOAT16))
+target_sources(CMSISDSPBasicMath PRIVATE ${SRCF16})
+endif()
+
+target_sources(CMSISDSPBasicMath PRIVATE ${SRCQ31})
+target_sources(CMSISDSPBasicMath PRIVATE ${SRCQ15})
+target_sources(CMSISDSPBasicMath PRIVATE ${SRCQ7})
+
+target_sources(CMSISDSPBasicMath PRIVATE ${SRCU32})
+target_sources(CMSISDSPBasicMath PRIVATE ${SRCU16})
+target_sources(CMSISDSPBasicMath PRIVATE ${SRCU8})
+
+configLib(CMSISDSPBasicMath ${ROOT})
+configDsp(CMSISDSPBasicMath ${ROOT})
+
+### Includes
+target_include_directories(CMSISDSPBasicMath PUBLIC "${DSP}/Include")
+
+
+