summaryrefslogtreecommitdiffstats
path: root/Drivers/CMSIS/DSP/Source/InterpolationFunctions/CMakeLists.txt
diff options
context:
space:
mode:
authorClyne Sullivan <clyne@bitgloo.com>2025-01-29 21:34:25 -0500
committerClyne Sullivan <clyne@bitgloo.com>2025-01-29 21:34:25 -0500
commit5b81bc8ccbd342b8566d88fc9f17a73aec03b5b6 (patch)
treecc57486912cfa74c6440d8b97c28f451ec787d78 /Drivers/CMSIS/DSP/Source/InterpolationFunctions/CMakeLists.txt
initial commit
Diffstat (limited to 'Drivers/CMSIS/DSP/Source/InterpolationFunctions/CMakeLists.txt')
-rw-r--r--Drivers/CMSIS/DSP/Source/InterpolationFunctions/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/Drivers/CMSIS/DSP/Source/InterpolationFunctions/CMakeLists.txt b/Drivers/CMSIS/DSP/Source/InterpolationFunctions/CMakeLists.txt
new file mode 100644
index 0000000..7ce79cf
--- /dev/null
+++ b/Drivers/CMSIS/DSP/Source/InterpolationFunctions/CMakeLists.txt
@@ -0,0 +1,34 @@
+cmake_minimum_required (VERSION 3.14)
+
+project(CMSISDSPInterpolation)
+
+include(configLib)
+include(configDsp)
+
+
+add_library(CMSISDSPInterpolation STATIC)
+
+target_sources(CMSISDSPInterpolation PRIVATE arm_bilinear_interp_f32.c)
+target_sources(CMSISDSPInterpolation PRIVATE arm_bilinear_interp_q15.c)
+target_sources(CMSISDSPInterpolation PRIVATE arm_bilinear_interp_q31.c)
+target_sources(CMSISDSPInterpolation PRIVATE arm_bilinear_interp_q7.c)
+target_sources(CMSISDSPInterpolation PRIVATE arm_linear_interp_f32.c)
+target_sources(CMSISDSPInterpolation PRIVATE arm_linear_interp_q15.c)
+target_sources(CMSISDSPInterpolation PRIVATE arm_linear_interp_q31.c)
+target_sources(CMSISDSPInterpolation PRIVATE arm_linear_interp_q7.c)
+target_sources(CMSISDSPInterpolation PRIVATE arm_spline_interp_f32.c)
+target_sources(CMSISDSPInterpolation PRIVATE arm_spline_interp_init_f32.c)
+
+
+configLib(CMSISDSPInterpolation ${ROOT})
+configDsp(CMSISDSPInterpolation ${ROOT})
+
+### Includes
+target_include_directories(CMSISDSPInterpolation PUBLIC "${DSP}/Include")
+
+
+
+if ((NOT ARMAC5) AND (NOT DISABLEFLOAT16))
+target_sources(CMSISDSPInterpolation PRIVATE arm_bilinear_interp_f16.c)
+target_sources(CMSISDSPInterpolation PRIVATE arm_linear_interp_f16.c)
+endif() \ No newline at end of file