summaryrefslogtreecommitdiffstats
path: root/Drivers/CMSIS/DSP/Source/QuaternionMathFunctions/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Drivers/CMSIS/DSP/Source/QuaternionMathFunctions/CMakeLists.txt')
-rw-r--r--Drivers/CMSIS/DSP/Source/QuaternionMathFunctions/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/Drivers/CMSIS/DSP/Source/QuaternionMathFunctions/CMakeLists.txt b/Drivers/CMSIS/DSP/Source/QuaternionMathFunctions/CMakeLists.txt
new file mode 100644
index 0000000..267626f
--- /dev/null
+++ b/Drivers/CMSIS/DSP/Source/QuaternionMathFunctions/CMakeLists.txt
@@ -0,0 +1,31 @@
+cmake_minimum_required (VERSION 3.14)
+
+project(CMSISDSPQuaternionMath)
+
+include(configLib)
+include(configDsp)
+
+
+
+add_library(CMSISDSPQuaternionMath STATIC arm_quaternion_norm_f32.c)
+target_sources(CMSISDSPQuaternionMath PRIVATE arm_quaternion_inverse_f32.c)
+target_sources(CMSISDSPQuaternionMath PRIVATE arm_quaternion_conjugate_f32.c)
+target_sources(CMSISDSPQuaternionMath PRIVATE arm_quaternion_normalize_f32.c)
+target_sources(CMSISDSPQuaternionMath PRIVATE arm_quaternion_product_single_f32.c)
+target_sources(CMSISDSPQuaternionMath PRIVATE arm_quaternion_product_f32.c)
+target_sources(CMSISDSPQuaternionMath PRIVATE arm_quaternion2rotation_f32.c)
+target_sources(CMSISDSPQuaternionMath PRIVATE arm_rotation2quaternion_f32.c)
+
+
+if ((NOT ARMAC5) AND (NOT DISABLEFLOAT16))
+endif()
+
+
+configLib(CMSISDSPQuaternionMath ${ROOT})
+configDsp(CMSISDSPQuaternionMath ${ROOT})
+
+### Includes
+target_include_directories(CMSISDSPQuaternionMath PUBLIC "${DSP}/Include")
+
+
+