summaryrefslogtreecommitdiffstats
path: root/Drivers/CMSIS/NN/Source/BasicMathFunctions/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Drivers/CMSIS/NN/Source/BasicMathFunctions/CMakeLists.txt')
-rw-r--r--Drivers/CMSIS/NN/Source/BasicMathFunctions/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/Drivers/CMSIS/NN/Source/BasicMathFunctions/CMakeLists.txt b/Drivers/CMSIS/NN/Source/BasicMathFunctions/CMakeLists.txt
new file mode 100644
index 0000000..9d3f543
--- /dev/null
+++ b/Drivers/CMSIS/NN/Source/BasicMathFunctions/CMakeLists.txt
@@ -0,0 +1,20 @@
+#
+# Copyright (c) 2019-2021 Arm Limited.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+file(GLOB SRC "./*_*.c")
+target_sources(cmsis-nn PRIVATE ${SRC})