summaryrefslogtreecommitdiffstats
path: root/Drivers/CMSIS/DSP/Source/BayesFunctions/CMakeLists.txt
diff options
context:
space:
mode:
authorClyne Sullivan <clyne@bitgloo.com>2025-01-29 21:34:25 -0500
committerClyne Sullivan <clyne@bitgloo.com>2025-01-29 21:34:25 -0500
commit5b81bc8ccbd342b8566d88fc9f17a73aec03b5b6 (patch)
treecc57486912cfa74c6440d8b97c28f451ec787d78 /Drivers/CMSIS/DSP/Source/BayesFunctions/CMakeLists.txt
initial commit
Diffstat (limited to 'Drivers/CMSIS/DSP/Source/BayesFunctions/CMakeLists.txt')
-rw-r--r--Drivers/CMSIS/DSP/Source/BayesFunctions/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/Drivers/CMSIS/DSP/Source/BayesFunctions/CMakeLists.txt b/Drivers/CMSIS/DSP/Source/BayesFunctions/CMakeLists.txt
new file mode 100644
index 0000000..72a202d
--- /dev/null
+++ b/Drivers/CMSIS/DSP/Source/BayesFunctions/CMakeLists.txt
@@ -0,0 +1,23 @@
+cmake_minimum_required (VERSION 3.14)
+
+project(CMSISDSPBayes)
+
+include(configLib)
+include(configDsp)
+
+file(GLOB SRC "./*_*.c")
+
+add_library(CMSISDSPBayes STATIC)
+
+target_sources(CMSISDSPBayes PRIVATE arm_gaussian_naive_bayes_predict_f32.c)
+
+configLib(CMSISDSPBayes ${ROOT})
+configDsp(CMSISDSPBayes ${ROOT})
+
+### Includes
+target_include_directories(CMSISDSPBayes PUBLIC "${DSP}/Include")
+
+if ((NOT ARMAC5) AND (NOT DISABLEFLOAT16))
+target_sources(CMSISDSPBayes PRIVATE arm_gaussian_naive_bayes_predict_f16.c)
+endif()
+